パスワードを忘れた? アカウント作成
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。

Google、古いAndroidのサポート終了か 9億台で脆弱性放置の恐れ」記事へのコメント

  • 残念ながら、現段階で4.4や5.0へのアップグレードが用意されていない
    端末には、今後も端末メーカーからアップグレードが提供される望みはないと思う。
    だからGoogleが4.3向けにWebViewのパッチを用意したとしても、
    ユーザの手元に届く可能性は少ない。

    一方、既存OS上で動くアプリが新OSの一部機能を利用するために
    アプリ開発者に対してSupport Libraryが配布されている。これにChrome
    ベースのWebViewコンポーネントを含めるべきだ。
    そうすればアプリケーションレベルでOS側のWebViewの脆弱性を回避できる。

    • by Anonymous Coward

      望みって言うが、
      自分の持ってる端末は、4.2から4.4にアップデートしたら、
      アプリからSDカード書き込みできなくなって、
      あるかどうかもわからない5.0を待ってるんだが。
      マジでアップデートしなければよかった。これはダウングレードに等しい。

      • by Anonymous Coward on 2015年01月15日 10時58分 (#2743795)

        4.4対応にあっぷしないその糞アプリが問題

        親コメント
        • 勘違いされているようなので書きます。

          4.4での変更で困るのは「ファイルマネージャ」など、
          「他のアプリのSD上のファイル・ディレクトリ」を扱うアプリです。

          これは、4.4に対応しても、OSの制限によりファイルを扱えなくなるからです。
          「ファイルを管理できないファイルマネージャ」に意味はないですので。

          これの回避策として、「ファイルマネージャをシステムアプリとして組み込む」というベンダもあります。

          が、ユーザが好きなファイルマネージャを使えないのは変わらない訳です。

          親コメント

皆さんもソースを読むときに、行と行の間を読むような気持ちで見てほしい -- あるハッカー

処理中...