パスワードを忘れた? アカウント作成
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。

Google、位置情報サービスをオフにしたAndroid端末からも基地局情報を収集していた」記事へのコメント

  • Android OS では、位置情報だけでなく、あなたの SNS アプリの通知 / 個人的な DM を含む、その他のプッシュメッセージを Google がスパイしています。また、Google が取得した情報は NSA の監視下にあります。このストーリーでは位置情報だけが触れられていますが、それだけではないのです。

    この記事は、よくあるアメリカを批判し、中国政府を正当化するための工作活動ではありません。アレゲな技術サイトスラドに相応しく、根拠となる技術的な説明をきちんとするので最後まで読んでください。

    メールの自動受信、通知欄への広告表示、お知らせなどを目的とするプッシュ通信は

    • GCMはAndroidの機能ではありません。
      GAppsと呼ばれるGoogle製アプリケーションの一つである「Google Play 開発者サービス」というアプリの機能です。
      GAppsは、オープンソースのAndroidとは違い、プロプライエタリなアプリケーションです。
      Open Handset Allianceに対しライセンス料を払わないとAndroidに組み込むことができません。
      なので、裏で何やってるのかなんてわかりませんし、バックドアを仕込んでも簡単にバレません。

      この「Google Play 開発者サービス」の機能が、Androidの機能として認識されているために、これに依存したアプリが非常に多いのです。
      GCM以外にも、YoutubeなどGoogleサービスのAPI、位置情報のAPI、Play Storeに関するAPIなどが含まれます。
      これがなければ、バックグラウンド状態のLINEの通知も届きませんし、ポケモンGOやJR東日本アプリ、先日リリースされたどうぶつの森などは起動すらしてくれません。

      7年前、GAppsをCyanogenmod(Androidのフォーク)に組み込み、Googleからライセンスしていないと警告されたことがきっかけで、
      このGAppsの代わりとして使用できる、microG [microg.org] や OpenGApps [opengapps.org] が開発されています。
      GCMに関しても、microGでは、GCMのサーバにアクセスする間隔を長くすることができたり、アプリごとに有効にするかどうかを選べます。

      親コメント
      • > この「Google Play 開発者サービス」の機能が、Androidの機能として認識されているために、これに依存したアプリが非常に多いのです。

        そちらさんが理解していない部分が入り込んでる

        スマホやタブレット(とか、その他)において「Android搭載のスマホ、タブレット(とか、その他)端末」を名乗るためには
        Googleに申請して承認してもらわないといけない
        この承認を採った時点でGAppsも使えるようになる

        それに対して、AOSPなどを野良ビルドして作った端末は
        「Android搭載のスマホ、タブレット(とか、その他)」を正式に名乗ってはいけない

        なので、KindleFireはAndroid端末ではなく、Android端末と名乗ることはできない

        ということで、「Android端末」が念頭にあるケースにおいては、そちらさんの指摘はまったくの筋違い
        Android端末を前提とするならGAppsはセットで提供されてるので何も困らない

        AndroidをベースにしたGoogle非承認端末でGAppsがないからアプリが動かないと言っても、それはAndroid端末の問題ではない

        ソフトウェアとしての「Android」はAOSPの部分も含まれるが、
        何かしらそれを動作させるハードは必ず必要になり、結局は上記ハードの次元で「Android端末なら動く、以上」だけの話になる

        親コメント
      • by Anonymous Coward

        この「Google Play 開発者サービス」の機能が、Androidの機能として認識されているために、これに依存したアプリが非常に多いのです。

        というか、ライセンス料を払わないといけないGAppsが無いとAPIが使えないようにした、というのが正しいか

最初のバージョンは常に打ち捨てられる。

処理中...