パスワードを忘れた? アカウント作成
10020941 story
Chrome

Google Chrome、古いタイプのプラグインサポートを廃止へ 23

ストーリー by hylom
プラグインの時代は終わりつつあるのか 部門より

長きにわたり、WebブラウザのプラグインはNetscape時代に作られた「NPAPI」というAPIで実装されていた。しかし、Google ChromeではNPAPIをサポートしていたものの、Google Chrome 21以降では「PPAPI」という新たなAPIが提供されており、Google Chrome向けのFlash PlayerなどはこちらのAPIを使って実装されている(窓の杜)。そして、次のステップとしてGoogle ChromeではNPAPIのサポート廃止を決めたようだ(TechCrunchChromium Blog)。

2014年1月以降、NPAPIプラグインはブロックされるという。また、NPAPIベースのプラグインを含む新規アプリおよび機能拡張については、GoogleのChromeウェブストアでの新規登録を9月24日より受け付けないとのこと。なお、Chromeユーザーが使っているNPAPIプラグインとしてはSilverlightやUnity、Google Earth、JAva、Google Talk、Facebook Videoなどがあるという。

この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
  • タレこみをみると2014年1月に使えなくなるみたいに見えますが、TechCrunchの記事を読むと若干ニュアンスが違うようですね。

    > Chromeが2014年1月以降、ウェブページでインスタンス化されたNPAPIプラグインをデフォルトでブロックする

    > 2014年中にはNPAPIサポートを完全に終了する計画だ

    > これらの(SilverlightとかGoogle Earth, Google Talk等利用者の多い)プラグインは、暫定ホワイトリストに載せられ、エンドユーザーや企業のシステム管理者は、他のプラグインも必要に応じてホワイトリストに載せることができる

    いくらなんでも短すぎるだろと思ったので安心(?)しました。
    --
    # yes, fly. no, fry.
    • by Anonymous Coward

      ウェブページ上で2014年1月に使えなくなるのは、そのとおりなのでは?
      webpage-instantiatedじゃないExtensionなんかはしばらくサポートされるんでしょうね。
      NPAPIがどうこうってのはBlinkとちょくせつ関係無いでしょうが、Operaは追従するんでしょうか。

      Mozilla FirefoxもNPAPI捨てると言ってるとすると、Android版FirefoxもAndroid版FlashPlayer使えなくなるんでしょうね。
      Android版ChromeはそもそもNPAPI非対応でしたから艦これできませんでしたが、Android版Firefoxで艦これできなくなるのか。

      • いやいや、動くと書いてあるように読み取れますね。
        とりあえず『Microsoft Silverlight、Unity、Google Earth、Java、Google Talk、およびFacebook Video』
        のうちJava以外は(ホワイトリストに入るので)そのまま動くようですし、ほかのプラグインもユーザー自らホワイトリストに入れられるとあります。

        タレこみは単にブロックだったので回避しようがないのかと思っていましたが「デフォルトで」ブロックなので設定を変えれば動くという事でしょう。

        これは想像の範囲ですが、古いFlashやAdobe Readerの時に表示される警告のようのなものがでるのかもなぁと思っています。

        (サポート完全終了後はどうなるかわかりませんがね)
        --
        # yes, fly. no, fry.
        親コメント
  • 将来的にはあるかもしれませんが、現時点でMozilla FirefoxがNPAPIのサポートを廃止する予定はありません。

    Implementing Pepper since Google is dropping NPAPI for good
    https://groups.google.com/forum/?hl=ja#!topic/mozilla.dev.platform/BwW... [google.com]

    以下のような誤報は、Flashを除くすべてのプラグインに初期設定でClick-to-Playが適用される仕様変更を誤解したものと思われます。
    https://developer.mozilla.org/ja/docs/Mozilla/Firefox/Releases/26/Site... [mozilla.org]

    MozillaはNPAPIプラグインを来たる12月に終了し
    http://jp.techcrunch.com/2013/09/24/20130923say-goodbye-to-npapi/ [techcrunch.com]
     ↑
    Mozilla will block NPAPI plugins in December
    http://techcrunch.com/2013/09/23/say-goodbye-to-npapi/ [techcrunch.com]
     ↑
    Mozilla plans to block NPAPI plug-ins in December 2013
    http://blog.chromium.org/2013/09/saying-goodbye-to-our-old-friend-npapi.html [chromium.org]

    • by Anonymous Coward

      うーん、そうなんだけど、Prestoの開発停止によって、NPAPIにわずかながら存在していた「クロスプラットフォーム性」は失われてしまったかな、という印象ですね。

      実際のところ、プラグイン自体にはOSの縛りが存在するので、今、新しいNPAPIのプラグインをVC++で作ったとして、それが使えるのはWindows版のFirefoxとSafariしかない、という状況は、あまり作者にとって嬉しい状況とはいえないでしょう。そういう点の魅力が薄れるのは避けられない。

      • by Anonymous Coward

        その例示だとWindows版Safariは実質サポートが終了してるのでFirefoxのみですね。
        ところで、Operaが忘れ去られているようですが……

        • by Anonymous Coward

          OperaはChrome追従に決まってるでしょ?

    • by Anonymous Coward

      Shumwayプロジェクトの進捗状況はどんな感じなんでしょうか?

  • by Anonymous Coward on 2013年09月25日 11時55分 (#2465623)

    ついでに止めるとか言わないよね?
    choromeに組み込んじゃえ!って考えもあるけどサイズが大きくなるよなぁ

    • by Anonymous Coward

      WebGLとWebRTCなどの標準技術でカバーするつもりでは?

      • by Anonymous Coward

        すでに新しいGoogleマップではWebGLによってEarthの機能が一部取り入れられてますしね。

        #イタリアのコロッセオ広場付近とかCorei5-2450MとAMD Radeon HD 6630Mで結構重い

    • by Anonymous Coward

      Google Talkってハングアウトですよね?
      ストアにあるんで継続するんでは。
      Earthはそれっぽいのない。やめるかもね。

      • by Anonymous Coward

        プラグインの話ですよ

  • by Anonymous Coward on 2013年09月25日 12時27分 (#2465636)

    小人さんの仕業です

    • by Anonymous Coward on 2013年09月25日 12時38分 (#2465641)

      どうでもいいなら書き込まなきゃいいのに。

      親コメント
      • by Anonymous Coward

        私もいつもそう思っているのでそんなことをいちいち書き込んだりしないのですが、
        クロムユーザは嫌いとか、使ってないとかわざわざ書き込むでしょ。だからクロムだけはいちいち書き込まないと失礼でしょ。同じようにして差し上げるのは礼儀作法の基本ですから。

    • by Anonymous Coward

      blinkエンジンに影響するならOpera とか SRWare Iron にも影響しそうだし
      そうなりゃandroid版の方も影響しそう。
      android は FireFoxしかflash対応できなくなりそう。

      • Androidは標準WebコンポーネントがFlashなどのプラグインに対応しています(少なくとも4.2の段階では)。これを使ったウェブブラウザーが標準添付されなくなったということで、対応ブラウザーを別途インストールすればFlashコンテンツが再生できます。ただまあご存知の通りAdobeのFlashプレイヤーが4.0までなので再生可能性に期待するのはちょっとなんですね。

        親コメント
      • by Anonymous Coward

        オープンソースなんだから必要ならフォークすればいい。
        まずは残してほしい言って。ダメなら該当処理が残っているバージョンからフォーク
        blinkの処理を吸収しながらサポートしていけいいのでは

  • by Anonymous Coward on 2013年09月25日 18時45分 (#2465916)

    GoogleのChromeというブラジャーがOppaiをサポートしないのか。
    そうか。

    • by Anonymous Coward

      レーシック難民って最終的にどうなるんですかね。

      • by Anonymous Coward

        中東に自分たちの国を作るんじゃないかな

typodupeerror

にわかな奴ほど語りたがる -- あるハッカー

読み込み中...