パスワードを忘れた? アカウント作成
12544729 story
Firefox

FirefoxがNPAPIのサポートについて発表、2016年末で利用不可に 34

ストーリー by hylom
WebGLへの以降は解決策なのだろうか 部門より
あるAnonymous Coward 曰く、

MozillaがNPAPIを使用したプラグインのサポートを2016年末で終了するとFuture Releasesブログで述べている。

NPAPI(Netscape Plugin Application Programming Interface)は1995年にリリースされたNetscape Navigatorで初めて導入されたプラグインAPIであり、さまざまなWebブラウザで採用されていた。しかし、Google ChromeではNPAPIについてセキュリティやパフォーマンスに問題があるとして、Google Chrome 45でNPAPIサポートを完全に廃止していた。

いっぽうでNPAPIを使用したプラグインは依然として存在しており、各プラグイン開発者は対応を迫られることとなった。その1つである「Unity Web Player」プラグインについては開発が打ち切られ、使用が非推奨になった(Unityの発表)。

Unity Web Playerが必須なブラウザゲームはいくつかあるが、それらゲームのサービスがどうなるのか注目される。

この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
  • by Anonymous Coward on 2015年10月13日 11時29分 (#2898677)

    Unity Web Playerが必須なブラウザゲームはいくつかあるが、それらゲームのサービスがどうなるのか注目される。

    ビジネスとしてやっている以上、改修に必要なコストに見合うだけのリターンが期待できないなら、
    放置もしくは終了するしかないでしょ。

    # ボランティアや趣味でやってるなら続けるでしょうが

    • by Anonymous Coward

      始まる前に死ぬことが確定したブラウザゲームがいくつかあって、何とも言えない気持ちになりますね。

      • by Anonymous Coward

        サービス開始から1年と4か月遊んだブラウザゲームが死にそうになってて割と困ってます。
        以前Google OpenID 2.0がサポート終わったときは対応してくれてたのですが、
        今回はゲーム本体の改修なんでだめそうですね・・・
        アニメも1期が終わって月一10分アニメになってしまったし。

        #ここまで書いたらなんのゲームか丸わかりである

    • by Anonymous Coward

      UnityはWebGL対応を進めるよと言ってるので、改修コスト自体は低く抑えられそうですけどね。

      • by Anonymous Coward

        今のところひどい状況でとても使い物にならない
        すんなり切り替えるなんて不可能です

      • by Anonymous Coward

        ニコニ立体はWebGLプレイヤー(UnityのWebGL出力を使用)に移行しましたけど、過去のUnityデータはUnityプレイヤーでないと閲覧できないそうなので、必ずしもスムーズに移行できるわけではないようです。WebGL向けに出力し直す必要があるけど、ユーザーは出力結果しかアップロードしていないから不可能ってことかな?

    • by Anonymous Coward

      ずっと前から廃止は既定路線だったのにそんなところに費用をつぎ込んだ最初の判断がそもそもおかしい。それこそ遊びでやってるんじゃないんだぞ。

  • by Anonymous Coward on 2015年10月13日 11時48分 (#2898689)

    こっちについても言及して欲しかったかな。

    Because Adobe Flash is still a common part of the Web experience for most users, we will continue to support Flash within Firefox as an exception to the general plugin policy.
    Mozilla and Adobe will continue to collaborate to bring improvements to the Flash experience on Firefox, including on stability and performance, features and security architecture.

    Flash Playerを切り捨てると影響が大きいので、例外としてサポートを続けるよ、と。(意訳)

    #最近FlashPlayerがよく固まって困る

    • by Anonymous Coward

      IEでもFlash Playerが特別扱いされているね。Unity Web Playerなんか保護モードや拡張保護モードが有効になっていると起動できないのに、Flash PlayerはWindows Updateで修正版が提供され、保護モードや拡張保護モードでも例外的に動作するんだからね。

    • by Anonymous Coward
      Chrome内蔵のPPAPI版のFlashPlayerってChrome以外では使いものにならないの?
      • GNU/Linux などの場合は、NPAPI上でPPAPIを動かすラッパーが作られてますね。
        https://github.com/i-rinat/freshplayerplugin [github.com]
        そこそこ使えますよ。

        親コメント
      • by Anonymous Coward

        PPAPIって、ChromeとOperaぐらいしか対応していないから、ChromeとOpera以外では使い物にならないよ。

      • by Anonymous Coward

        それ以前に、Chromeでも不安定で使いものにならない印象
        もっとオープン化して揉まれりゃもうちょっと使い物になってくるんだと思うんだが。

        • by Anonymous Coward
          今のところ特に不安定という印象はないけどなぁ。
          Chrome使い始めて5ヶ月ぐらい経つけど、FlashPlayerが落ちた記憶は今のところないし。
          気づいてないだけかもしれないけど。

          PPAPI版のFlashPlayerでニコ動で設定を覚えてくれない問題があったが、
          Chromeの設定変えたら問題なくなったし。

          「サードパーティのCookieとサイトデータをブロックする」をONにしてると警告が出る。
          これをOFFにするか、例外に「[*.]nicovideo.jp」を追加すれば問題なくなる。
          • by Anonymous Coward

            落ちる以前に動作しないイメージだな。

          • by Anonymous Coward

            ニコ動で赤点滅起こす元凶がPPAPIなんだけど・・・

            以前は切ってNPAPI使ってたのに、わざわざ潰すとかゴミすぎる

        • by Anonymous Coward

          動画はコマ落ちするしホント使えない

        • by Anonymous Coward

          PDFの辿ってきた道と同じで、ベース部分だけでも標準規格化されないとどうにもならんのかな…

      • by Anonymous Coward

        Linux 限定ですが、
        https://github.com/i-rinat/freshplayerplugin [github.com]
        こんなのがあります。

    • by Anonymous Coward

      > FlashPlayerがよく固まって困る
       
      FirefoxならOMTCとOOPPを無効にすれば安定するかも
      about:configかConfiglationManiaでどうぞ

      • by Anonymous Coward

        FirefoxならOMTCとOOPPを無効にすれば安定するかも

        残念ながらどちらも効果は有りませんでした。
        ただ、FlashPlayerの保護モードを無効にしてみると言う情報も有り、
        これで安定したようなので、しばらくこのまま運用してみます。

  • by Anonymous Coward on 2015年10月13日 11時33分 (#2898678)

    Linux サポートのないまま Unity Web Player がなくなってしまうのか…

    • by Anonymous Coward

      UnityはWebGL対応を進めるようですから、むしろLinuxでUnityコンテンツが動く可能性は上がるのではないでしょうか。
      (動作を保証されるかどうかは別として)

    • by Anonymous Coward

      Pipelightを使うことでLinux上で動かすことは今までも出来ましたし、WebGL対応によってネイティブで動くようになるのでは。

  • by Anonymous Coward on 2015年10月13日 13時00分 (#2898734)

    なくすからには、新しいAPI側にはNPAPIとイコールの機能のAPIが提供されているんだよね?

    • by Anonymous Coward on 2015年10月13日 13時34分 (#2898758)

      そもそもMozillaはPPAPIへの対応に積極でありません。3年前はPPAPIに興味は無いと言っていました [linux.srad.jp]が、それ以降変わったという話は聞いたことないです。

      親コメント
      • by Anonymous Coward

        それ以前にPPAPIプラグインはNPAPIの置き換えになりませんよ。PPAPI FlashがAdobeのサイトからあたかもNPAPIプラグインのように普通にインストールできるのは、わざわざChromium側で特別対応しているからです。それ以外のプラグインはサードパーティーのサイトからインストールさせることができません(Native Messaging経由でChromeウェブストアに登録したエクステンションからプラグインを登録するとか回りくどいことをする必要がある)。
        そもそもネイティブコードを好き勝手に実行できるものをランダムなサイトからインストールできるというモデル自体が危険だったというのがNPAPI廃止の口実でしたから、この制限は意図的なものですし外されることもないでしょう。Chrome付属のもの以外にPPAPIプラグインが存在しないのは、別にサードパーティーが対応をサボっているからではなく、Chromeに標準で付属させるという手が使えるGoogle以外にとって事実上使いものにならないからです。

    • by Anonymous Coward

      HTML5が代わりになる…と廃止推進派は考えているらしい。
      個人的には、HTML5は低レベルな要素技術で、「原理的には」同じことができるというだけに思える。
      具体的には、オーサリング環境がまったく追いついていないように見える。

      • by Anonymous Coward

        とりあえず、話は WebAssembly [techcrunch.com] が各ブラウザでサポートされてからですかねぇ。

        # 結構期待してるんだけど、いつになるんだろうなぁ

      • by Anonymous Coward

        早すぎたバブルのせいでHTML5という単語にこういう先入観を持たれるようになってしまったので、巻き返すにはそろそろ新しいバズワードが必要ですな。

  • by Anonymous Coward on 2015年10月13日 13時42分 (#2898768)

    Chromeベース以前のOperaもNPAPIなんだよね。なので、NPAPIは残ってほしいんだが、Flash Playerだけサポートしてくれればいいかな。

  • by Anonymous Coward on 2015年10月13日 20時01分 (#2899058)

    そういえば、Shumway [mozilla.org]って開発進める気あるんだろうか。

    「お!、やってるね!」と思ったら、「ん? 開発やめたのかしら?」というくらい静になる。
    現在は後者かな?

typodupeerror

皆さんもソースを読むときに、行と行の間を読むような気持ちで見てほしい -- あるハッカー

読み込み中...